Author [NL] [FR] [ES] [DE] [SE] [IT] Topic: Garmin 660 Problem  (Read 2244 times)

0 Members and 1 Guest are viewing this topic.

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Garmin 660 Problem
    on: Sep 25, 2020, 05.07 pm
    Sep 25, 2020, 05.07 pm
    Hello,
     I went to use my 660 GPS and found it only works through its own speaker. I checked the Jack connection was OK to the bike under the left indicator. All was good but still nothing through the bike speakers or headset when switched over. I have not changed any settings. However I had the Ignition wiring and locks changed under the recall and wonder if something was disconnected?
    Any Ideas?
    Cheers
    Wayne :084:

  • Offline Coconut   gb

    • Trophy God  ‐    10000
    • *****
      #1

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10000
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Garmin 660 Problem
    Reply #1 on: Sep 25, 2020, 05.57 pm
    Sep 25, 2020, 05.57 pm
    Have you checked in the Audio Settings Menu that NAV AUDIO is set to "ON" ?

    Press and Hold "M" = Radio Set Up
    Scroll to ALT SOURCE & Press "i"
    Scroll to NAV AUDIO & Press "i"

    If it says NAV AUDIO OFF that's the reason -

    Scroll to "ON" & Press "i"
    Scroll to EXIT & Press "i"
    Scroll to EXIT & Press "i"

    Cheers  :821:



  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #2

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Garmin 660 Problem
    Reply #2 on: Sep 25, 2020, 06.23 pm
    Sep 25, 2020, 06.23 pm
    Hi Coconut,

    Yes I have already checked and it is on. I even switched it off then back on. No joy. I will try and trace the feed to the jack plug from its power source to see if it has been disconnected or damaged somehow.  :187:

    Just seems strange that it was working before the recall work and immediately after its not.

  • Offline Coconut   gb

    • Trophy God  ‐    10000
    • *****
      #3

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10000
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Garmin 660 Problem
    Reply #3 on: Sep 25, 2020, 06.45 pm
    Sep 25, 2020, 06.45 pm
    Assuming the Output Volume of the Garmin
    hasn't been inadvertently lowered to zero or Muted  :138: ....

    Check the Pins are all intact and clean on the back of the 660,
    and at the corresponding connections of the Cradle mount.

    This is an Image showing the connections at the Cradle :



    If you have a Test Meter, you could check for Continuity from the 3 connections
    at the Cradle to the 3 connections of the Jack Socket at the end of the Garmin harness
    that is connected to the Trophy Audio 3.5mm Jack Plug.

    Pin 10 "HPL" - External Headphone Output - Left
    Pin 11 "HPCOM" - External Headphone Output - Common
    Pin 12 "HPR" - External Headphone Output - Right

    Cheers  :821:



  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #4

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Garmin 660 Problem
    Reply #4 on: Sep 25, 2020, 07.04 pm
    Sep 25, 2020, 07.04 pm
    Thanks Coconut,

    The volume is on full for the Garmin. I will do the pin test and see if there is power to the 3.5mm plug and let you know asap. Thanks for the diagram, I appreciate it.

    Wayne

  • Offline Coconut   gb

    • Trophy God  ‐    10000
    • *****
      #5

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10000
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Garmin 660 Problem
    Reply #5 on: Sep 25, 2020, 07.16 pm
    Sep 25, 2020, 07.16 pm
    You're not looking for "Power" as such ( as in 12 volts ) on the Audio connections,
    just Continuity from the Cradle end to the  other end where it connects to the Trophy Audio Plug.

    12 Volts "Power" for the Garmin is provided via a separate connection
    with a plug & socket in the same area below the left mirror pod.

    Cheers  :821:



     

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #6

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Garmin 660 Problem
    Reply #6 on: Sep 26, 2020, 01.28 pm
    Sep 26, 2020, 01.28 pm
    Sorry, I meant continuity.

    The problem is fixed. I was about to start the pin test but decided to clean the contacts on the back of the Garmin and the pins on the housing first.  I found pin 11 (HP Com) sticking because of contamination. It looked like tree sap or glue like substance. Not sure how it got there.  I cleaned everything with contact cleaner and the GPS now works perfectly. Many thanks for your input Coconut.

    Wayne  :001:

  • Offline Coconut   gb

    • Trophy God  ‐    10000
    • *****
      #7

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10000
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Garmin 660 Problem
    Reply #7 on: Sep 26, 2020, 01.30 pm
    Sep 26, 2020, 01.30 pm
    Thanks for the update - Glad to have been able to help !  :028:

    Cheers  :821:




     



    tweedy-bunch