Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: 'I' button not functioning  (Read 303 times)

0 Members and 1 Guest are viewing this topic.

Offline rpeters549

  • Trophy Master
  • ****
  • Posts: 686
    • View Profile
  • Bike: 2015 Trophy SE
  • City / Town: Lowell, Or
  • Country: USA
'I' button not functioning
« on: January 16, 2021, 07:28:52 pm »
Turns out my 'I' button on the left hand cube under the radio buttons is not working.  Found out when I went to adjust the headlamp angle and adjust the clock.

On my Goldwing (GL1500) when I had it, it was a maintenance thing to annually spray a bunch of electrical contact cleaner, WD40 or equivalent in the switches because over time rain/dust/etc would gunk up the switch.

Assuming it is the same thing?  I tried to pull DTC's a month or so ago and it took a dozen tries, probably because this button was not doing it's thing.

So, have any of y'all had luck just sticking the red pipe on the aerosol can against the crack of the switch, take them off the bars to access, what?
Year round rider here!

Offline STJIM

  • Trophy Pro
  • ***
  • Posts: 208
    • View Profile
  • Bike: 2015 TTSE ( Blue )
  • City / Town: West Michigan
  • Country: USA
Re: 'I' button not functioning
« Reply #1 on: January 17, 2021, 01:56:17 am »
Don't use regular WD40, use an electrical contact cleaner.  My local ACE Hardware stocks the CRC brand.

WD does make a contact cleaner, but that isn't what most people mean when they refer to "WD40".

« Last Edit: January 17, 2021, 02:00:39 am by STJIM »
IBA #35372
BBG  5-2014
SS3K 9-2020
2015 TTSE , 2008 Concours C-14
1998 ST1100

Offline rpeters549

  • Trophy Master
  • ****
  • Posts: 686
    • View Profile
  • Bike: 2015 Trophy SE
  • City / Town: Lowell, Or
  • Country: USA
Re: 'I' button not functioning
« Reply #2 on: January 17, 2021, 02:07:41 am »
I have a can of the same contact cleaner. On the 'Wings different folks used different products.

Just wondering if others have had this issue and whether the cube had to come off to clean it or if they had good luck shooting it in the side of the switch.

It's what I get I suppose for being a four season rider. 34 k now! Not bad for a bit over 4 years and no touring. Yet.
Year round rider here!