Author [NL] [FR] [ES] [DE] [SE] [IT] Added heated seat.....  (Read 649 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Conan   us

    • Trophy Junior  ‐    7
    • *
    • Topic Author

    Offline Conan

    • Trophy Junior
    • *
    • Topic Author
    • Posts: 7
    • Bike: Trophy SE
    • City / Town: North Berwick
    • Country: us
    Added heated seat.....
    on: Feb 11, 2024, 12.06 am
    Feb 11, 2024, 12.06 am
    OK....I was going to reply to a related post but message indicates it is past 120 days and I should start a new one.
    I purchased a 2017 and just installed a new heated seat with sub harness and switch. Looks to be plug n play or am I wrong to assume. Heated grips worked until I installed the seat....now neither seat or grips work. Heated grips icon was showing prior to plugging in seat but is now vacant on display. Isn't the harness wired for the addition of a seat? All parts are OEM. I disconnected the battery to reset the system. Checked fuse, it's fine. Still No go.
    Am I missing something or is it that the dealership simply has to plug in to the ECM to make the changes? Appreciate any help.

  • Offline ladisney   us

    • Trophy Member  ‐    86
    • **
      #1

    Offline ladisney

    • Trophy Member
    • **
    • Posts: 86
    • Bike: 17 Trophy SE
    • City / Town: Pleasant Hill, Iowa
    • Country: us
    Re: Added heated seat.....
    Reply #1 on: Feb 11, 2024, 04.48 am
    Feb 11, 2024, 04.48 am
    I added both the heated seat and grips simply by putting them on and plugging them in.  They both worked fine when I flipped the switches.  The dealer was not involved and, as far as I know, there were no updates required.

  • Offline trophied   us

    • Trophy God  ‐    5645
    • *****
      #2

    Offline trophied

    • Trophy God
    • *****
    • Posts: 5645
    • Bike: 2017 Trophy SE
    • City / Town: New Braunfels, Tx
    • Country: us
    Re: Added heated seat.....
    Reply #2 on: Feb 11, 2024, 11.18 pm
    Feb 11, 2024, 11.18 pm
    Without seeing any of the connections is the switch connected by spade connectors and if so are those possibly reversed.  I'll go look around to see if I can find info about it in the manual and the parts breakdowns, but I don't have heated seats so it will at best be a guess.
    One of the Founding Members of the Twisted Trophies

  • Offline Coconut   gb

    • Trophy God  ‐    10626
    • *****
      #3

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10626
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Added heated seat.....
    Reply #3 on: Feb 12, 2024, 08.30 am
    Feb 12, 2024, 08.30 am
    Hi ladisney,

    It should all be Plug and Play - with a couple of caveats :

    With everything connected correctly, be aware that the Heated Seats and Grips ONLY work when the engine is running
    AND when the Battery is in good fully charged condition - If low voltages are detected the Accessory circuit is temporarily
    disabled until the Battery voltage ( figure not specified ) returns to "normal" voltage ( whatever that is ! ).

    With the engine running and battery tested and known to be good, if you unplug the new Heated Seat connection(s),
    do the Heated Grips then work again ?  If so this indicates a problem with the Heated Seat installation.


    The installation instructions for the Heated Seats are not too clear in my opinion.
    ( Not helped by the unreliable wiring diagram for the Accessory circuit in the Service Manual which has ERRORS ! )
    They include instructions for 3 variations of installation :

    • Heated Rider seat only
    • Heated Pillion Seat only
    • Heated Rider and Pillion seats

    Read the instructions carefully and apply them as they relate to your specific installation,
    making sure you have plugged everything in to the correct sockets after removing the Blanking Plugs as described.

    Installation instructions are available here :

    Triumph Instructions.com

    A final consideration is that it is possible for a Dealer, or by use of an After Market device such as DealerTool
    to disable the Instrument Panel display of the Heated Grips and Heated Seats Icons, although the
    Heated Grips and Seat(s) will still heat up, but without the Icons appearing on the Instrument panel display.
     
    Hope this helps  :028:

    Last Edit: Feb 12, 2024, 08.36 am by Coconut

  • Offline Conan   us

    • Trophy Junior  ‐    7
    • *
    • Topic Author
    • #4

    Offline Conan

    • Trophy Junior
    • *
    • Topic Author
    • Posts: 7
    • Bike: Trophy SE
    • City / Town: North Berwick
    • Country: us
    Re: Added heated seat.....
    Reply #4 on: Feb 12, 2024, 05.03 pm
    Feb 12, 2024, 05.03 pm
    I did replace the battery over the weekend since battery was showing low voltage. Still no go. Heated grips worked find and icon was showing on display prior to plugging in seat. Did not modify any wiring. Just plugged in sub harness, switch and seat. Now no icon or grips working. Called dealer and they indicate it may have seen a change in the system and disabled both grips and seat. Doesn't seem logical to me but would not be surprised if that is the case.
     I will try to find a local mechanic with the scanner tool to program. Dealer is too far from me but if I have too............will head over there when the snow thaws.
    Thx for all the feed back.

  • Offline Conan   us

    • Trophy Junior  ‐    7
    • *
    • Topic Author
    • #5

    Offline Conan

    • Trophy Junior
    • *
    • Topic Author
    • Posts: 7
    • Bike: Trophy SE
    • City / Town: North Berwick
    • Country: us
    Re: Added heated seat.....
    Reply #5 on: Feb 12, 2024, 10.11 pm
    Feb 12, 2024, 10.11 pm
    I went ahead and purchased the dealertool. Hopefully that will remedy the issue. Thx to all.

  • Offline Coconut   gb

    • Trophy God  ‐    10626
    • *****
      #6

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10626
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Added heated seat.....
    Reply #6 on: Feb 13, 2024, 02.26 pm
    Feb 13, 2024, 02.26 pm
    Iím not sure it will !

    You didnít say whether you had tried disconnecting the new heated seat arrangement, and whether doing so restored the Heated Grips function, or whether it was just the Instrument Panel display that was not working, with the Grips and seat still heating up when switched on ?

    The DealerTool device can only enable or disable the Instrument Panel display Icons for Heated Grips or Seats, it canít enable them to work or disable them from working, as far as I know !

    Cheers 🍻


  • Offline Conan   us

    • Trophy Junior  ‐    7
    • *
    • Topic Author
    • #7

    Offline Conan

    • Trophy Junior
    • *
    • Topic Author
    • Posts: 7
    • Bike: Trophy SE
    • City / Town: North Berwick
    • Country: us
    Re: Added heated seat.....
    Reply #7 on: Feb 13, 2024, 10.33 pm
    Feb 13, 2024, 10.33 pm
    We will find out....I wanted to get the tool either way for future use. Thx for all the help. I will figure it out. I'm pretty tenacious.