Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: Trophy SE Cardio Bluetooth issues  (Read 4312 times)

0 Members and 1 Guest are viewing this topic.

Offline racsw

  • Trophy Member
  • **
  • Posts: 41
    • View Profile
  • Bike: 2014 Trophy SE
  • City / Town: Rochester
  • Country: USA
Trophy SE Cardio Bluetooth issues
« on: November 02, 2013, 10:32:48 PM »
Hi,
Are other owners having Cardio Bluetooth connectivity issues?
I have a new Q3 system I bought just prior to buying the Triumph, and every time I speak into the mic when listening to the XM Radio, the Radio cancels, as it should, to listen to the conversation, but never comes back on.
I have to shut the Cardio off, then turn it back on and wait for it to Pair, then the radio comes back on again.

If I should even cough into the mike, the problem repeats.
I bought this system, because some research pointed to the Cardio and Sena being the top two rated systems, and my Dealer had Cardio.  $400.

Triumph says its the Cardio units fault, not Triumph. (Of course they would)

Can anyone confirm this and provide a compatible solution?

Thanks,
Robert

Offline Thunestvedt

  • Trophy Member
  • **
  • Posts: 69
  • Ride proud
    • View Profile
  • Bike: Triumph Trophy SE
  • City / Town: Fitjar
  • Country: Norway
Re: Trophy SE Cardio Bluetooth issues
« Reply #1 on: November 03, 2013, 01:17:41 PM »
I have problems with my Scala Rider G9, sounds comes and goes, very frustrating. I really hope the software update of the bike will take care of it. Meanwhile, maybe you can try turning down VOX sensitivity on your headset?
Davy Crockett MC
Triumph Trophy SE
ST 1300 (gone)
Suzuki Intruder (gone)
Kawazaki Vulcan (gone)

Offline racsw

  • Trophy Member
  • **
  • Posts: 41
    • View Profile
  • Bike: 2014 Trophy SE
  • City / Town: Rochester
  • Country: USA
Re: Trophy SE Cardio Bluetooth issues
« Reply #2 on: November 03, 2013, 04:09:11 PM »
Well, from what I've been able to dig up online, Triumph has a lot of Bluetooth issues.
It isn't just one manufacturer, it's Cardio, Sena, even Ipod Bluetooth problems.
I'll turn down the VOX setting, but I don't think that's the main problem.

Offline w8d4it

  • Trophy God
  • *****
  • Posts: 5337
    • View Profile
  • Bike: 2013 Triumph Trophy
  • City / Town: Houston Texas
  • Country: USA
Re: Trophy SE Cardio Bluetooth issues
« Reply #3 on: November 04, 2013, 02:17:40 AM »
I'm not entirely sure it is the Trophy.  I have problems with communicating with the passenger intercom even  when we are on a bike other than the Trophy.  I feel the new Scala does not work as well as the previous generation.
« Last Edit: November 05, 2013, 10:45:31 AM by w8d4it »
Proudly Riding Triumph Since 1968
2013 Triumph Trophy SE
2001 Sprint 955 ST

Offline Fireman73163

  • Trophy Member
  • **
  • Posts: 63
    • View Profile
  • Bike: 2014 Trophy SE
  • City / Town: Miles, IA
  • Country: USA
Re: Trophy SE Cardio Bluetooth issues
« Reply #4 on: November 05, 2013, 02:40:30 AM »
I run a Cardio Q2 pro headset paired to my Zumo 660, paired to my phone...this setup works fine ! Get my navigation and can place and recieve calls. I have my I-pod touch hooked up to the USB port on the bike and play thru the speakers. This setup has been working great, I might try pairing the headset to the TT, but am afraid to with what I have read...

Offline mototux

  • Trophy Pro
  • ***
  • Posts: 222
    • View Profile
  • Bike: Triumph Trophy SE
  • Country: Other European
Re: Trophy SE Cardio Bluetooth issues
« Reply #5 on: November 14, 2013, 06:45:39 PM »
Same issue here with a Q3  :087:  Anytime I'm riding alone and accidentally "cough" into the mike, the music fades and never returns. Not really convinced it is all Cardio's fault. But then again, I haven't played with all settings of the Q3, yet. Unfortunately, the winter is showing it's first appearance over here (I live in Switzerland) and I will be on business-trip for the next couple of days - so I won't be able to verify this any time, soon.

Will keep you posted if I find a solution to this.
When everything seems to be going against you, remember that the airplane takes off against the wind, not with it.

Offline bentroad

  • Trophy Junior
  • *
  • Posts: 3
    • View Profile
  • Bike: Trophy SE 2013
  • City / Town: Lakeland, FL
  • Country: USA
Re: Trophy SE Cardio Bluetooth issues
« Reply #6 on: November 26, 2013, 11:12:07 PM »
Is anyone having issues with the Trophy Bluetooth and a Scala G4?
Myself and two friends each purchased a 2013 TTSE and we all have Scala Rider G4 headsets. We are all experiencing  similar issues. Pairing the G4 to the Trophy is no problem, that process goes smoothly. After pairing and during a ride the audio will sometimes cut out leaving only silence. The audio always returns though it comes and goes too frequently. There is also a positional component that we all experience. When turning our head to the right, the audio goes silent. The audio will reconnect after a few seconds (or longer). This positional issue is not a loose wire. The problem is reproducible with different helmet headsets and different G4’s.
The G4’s work fine with all connections tested except for the Trophy. The G4’s will also loose their connection with the Trophy if I walk just a couple of feet from the bike.  The same G4 had remained connected to my phone left accidentally left inside my home while I was in my garage separated by at least twenty feet and two walls.
Triumph said the issue was likely due to incorrect pairing in spite of my declaration that proper instructions were followed and the bike indicated a good pairing. So today I paired the G4 to the Trophy with two technicians as witnesses only to have the same issues pop up (what a surprise!). Now the dealer will call Triumph again to see what they suggest.
It is really frustrating that the Bluetooth does not work as expected.

Offline Desertaire

  • Trophy Pro
  • ***
  • Posts: 186
    • View Profile
  • Bike: 2013 Trophy SE
  • City / Town: El Paso TX
  • Country: USA
Re: Trophy SE Cardio Bluetooth issues
« Reply #7 on: November 27, 2013, 12:39:30 AM »
Same thing here with my Scala Rider G4. Glad to know its not just me.