Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: Well , well ...?  (Read 2379 times)

0 Members and 1 Guest are viewing this topic.

Offline Bythebay

  • Trophy Pro
  • ***
  • Posts: 193
  • Gender: Male
    • View Profile
  • Bike: Trophy SE
  • City / Town: Collingwood
  • Country: Canada
Well , well ...?
« on: January 31, 2013, 05:56:51 PM »
Talked with my dealer here in Ont. Canada yesterday re concern about alternator battery issues , thought of ordering an alternator to take on trip as I hear there have been faulty ones and they are in short supply from Triumph , so they called Triumph North America in the States .
They say they have had no alternator warranty issues and only one battery issue !
And by the way the alternator is 709.00 can . WOW !
Any advise ....?
Not sure how many Trophies in Can. and US
Will check to see if the faulty reports on both are from UK or here ....
Live long , ride hard and prosper ...!

Offline clarge

  • Trophy Pro
  • ***
  • Posts: 124
    • View Profile
  • Bike: Triumph Trophy SE
  • City / Town: Qualicum Beach
  • Country: Canada
Re: Well , well ...?
« Reply #1 on: January 31, 2013, 06:55:23 PM »
As before I do think they share the same alternator as the Explorer. I have not heard of any problems on that end. Me I wouldn't worry about. Not much can go wrong with an alternator now a days.

Offline Canucks_Fan

  • Trophy Pro
  • ***
  • Posts: 159
  • Gender: Male
    • View Profile
  • Bike: Tiger 1050 Trophy SE
  • City / Town: Kennewick
  • Country: USA
Re: Well , well ...?
« Reply #2 on: January 31, 2013, 08:35:35 PM »
They flat out lied to you- I know for a fact that they have had at least one bad alternator.  Call them again and ask them to look up vin# 571990 and see what they say.


Offline Bythebay

  • Trophy Pro
  • ***
  • Posts: 193
  • Gender: Male
    • View Profile
  • Bike: Trophy SE
  • City / Town: Collingwood
  • Country: Canada
Re: Well , well ...?
« Reply #3 on: February 01, 2013, 09:16:35 PM »
And that one being yours ? Saw the pic of the naked girl ... Was that at your dealers shop ? What is your dealers name ?
Live long , ride hard and prosper ...!

Offline Canucks_Fan

  • Trophy Pro
  • ***
  • Posts: 159
  • Gender: Male
    • View Profile
  • Bike: Tiger 1050 Trophy SE
  • City / Town: Kennewick
  • Country: USA
Re: Well , well ...?
« Reply #4 on: February 01, 2013, 09:27:31 PM »
*Originally Posted by Bythebay [+]
And that one being yours ? Saw the pic of the naked girl ... Was that at your dealers shop ? What is your dealers name ?
yes. It's at Thunder Alley in Kennewick,WA.  I have lots of pics of her stripped, and one of the alternator sitting on the counter.

Offline Bythebay

  • Trophy Pro
  • ***
  • Posts: 193
  • Gender: Male
    • View Profile
  • Bike: Trophy SE
  • City / Town: Collingwood
  • Country: Canada
Re: Well , well ...?
« Reply #5 on: February 01, 2013, 11:36:17 PM »
Ok , Canucks Fan , the truth will always shine through .... !
Just trying to gather if you are a one off .... Or is it a trait ...?  :084:
Live long , ride hard and prosper ...!

Offline ThickBrit

  • Trophy Pro
  • ***
  • Posts: 113
    • View Profile
  • Bike: 2 x TT, now an SE
  • Country: UK
Re: Well , well ...?
« Reply #6 on: February 01, 2013, 11:53:24 PM »
Taking all this into account - and noticing I've had a little engine noise, I checked in at my dealership today.
There was a shim/bucket issue but on checking the VIN, mine's been fixed already.

Also learned that when the temp goes below 3 or 4 degrees the digital speedo is supposed to cut out - to make you think about slippy-slidey. So it was the cold that did it but not in the way I thought.

Also, re oil level checking. Run engine for 5 minutes, stop it and let it cool for 3 minutes, then check sight glass.
Different viscosity of oil these days, so it flows differently. So don't try to check it cold is the message. It is in the manual, but it helped to get it confirmed in normal English.....

Alternator problem is apparently an ECU issue owing to different emissions outside Europe - needs a different tune.

My screen wouldn't lower yesterday. Had to switch off and re-set. Hasn't done it again since though.
« Last Edit: February 03, 2013, 03:46:12 PM by ThickBrit »
DVSA registered post-test motorcycle trainer.

Offline Bythebay

  • Trophy Pro
  • ***
  • Posts: 193
  • Gender: Male
    • View Profile
  • Bike: Trophy SE
  • City / Town: Collingwood
  • Country: Canada
Re: Well , well ...?
« Reply #7 on: February 02, 2013, 12:11:32 AM »
So your engine noise is normal for the bike ? Though you thought it wasn't ...?
So I apologize , what would the emission control have to do with the alternator ...?   
Live long , ride hard and prosper ...!

 


tweedy-bunch