Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: Electrical problems log and discussions  (Read 4273 times)

0 Members and 1 Guest are viewing this topic.

Offline Papermaker

  • Trophy Pro
  • ***
  • Posts: 269
    • View Profile
  • City / Town: Custer, WI.
  • Country: USA
Electrical problems log and discussions
« on: January 09, 2014, 03:59:39 PM »
All--

In addition to various radio and communication problems the Trophy seems to suffer from at least four bike related electrical problems (I seen these problems mentioned several times by forum members).

-- Bad or weak batteries
-- Low voltage warnings while starting.
-- No response from the e-start when the starter button is pushed (at the start, middle or end of a ride).
-- Dead battery/bike after sitting overnight or longer.  Not caused be switch in park position.

I've experienced low voltage and no e-start response.  I was hoping that my bike had a weak/bad battery but that doesn't seem to be the case based on voltage drop while starting.

Are there other issues that I've missed?

--John

Offline Coconut

  • Trophy God
  • *****
  • Posts: 8748
    • View Profile
  • Bike: 2017 Trophy SE
  • City / Town: South Birmingham
  • Country: UK
Re: Electrical problems log and discussions
« Reply #1 on: January 09, 2014, 04:08:52 PM »
Hi John,

Have you had a browse through this one : HOW TO : Check the most common faults and issues" ?
( That's the link to Page 1 - There are now 2 pages, but you'll find a Link for Page 2 on Page 1, and vice-versa  :028:



Offline Papermaker

  • Trophy Pro
  • ***
  • Posts: 269
    • View Profile
  • City / Town: Custer, WI.
  • Country: USA
Re: Electrical problems log and discussions
« Reply #2 on: January 09, 2014, 04:29:00 PM »
Hi Coconut--

Thanks for the link.  If forum members are willing, I'd like to have a stand alone, active discussion of the electrical problems listed and others that I am not be ware of.

For instance, are these problems related?  A weak/bad battery may generate some of these issues but my battery and other forum member's batteries have been checked/replaced without correcting the issues.

I think that an active discussion will be helpful in resolving these issues,

--John

Offline LongRanger

  • Ex Member
  • *
  • Posts: 53
    • View Profile
  • Country: Not disclosed
Re: Electrical problems log and discussions
« Reply #3 on: January 09, 2014, 05:19:34 PM »
A good video for anyone wanting to find a fault.



How To Perform a Parasitic Draw Test - EricTheCarGuy

Offline Coconut

  • Trophy God
  • *****
  • Posts: 8748
    • View Profile
  • Bike: 2017 Trophy SE
  • City / Town: South Birmingham
  • Country: UK
Re: Electrical problems log and discussions
« Reply #4 on: January 09, 2014, 05:58:28 PM »
I'd like to have a stand alone, active discussion of the electrical problems listed and others
Good idea  :028:

I haven't had any of the Low Voltage / Low Battery warnings as such,
but did ( and still do ) have an issue which I'm convinced isn't right,
where sometimes, but not always, when I sound the horn ( while riding along ) - the audio cuts out,
and the Intrument Panel displays "NO DEVICE" ! ??
A few seconds after "beeping" the horn, the audio comes back on again with no problem.

My dealer checked with Triumph who said it was "normal" and is something to do with the alternator,
which apparantly varies its output, rather than pushing out full Amps constantly ????

I cannot replicate the fault ( or feature ? ) at will, it just seems to happen at random times -
not that I use the horn that much, but it has defintitey happened when there was no other major load
such as heated seats or grips switched on.

The original discussion was here : Audio Cuts Out When Sounding the Horn !

Offline johnbut

  • Trophy Pro
  • ***
  • Posts: 215
    • View Profile
  • Bike: triumph trophy
  • City / Town: East Yorkshire
  • Country: UK
Re: Electrical problems log and discussions
« Reply #5 on: January 09, 2014, 06:03:38 PM »
Are the electrical faults limited to the trophy se or have any standard models had battery problems?

Offline Briang1234

  • Non Active
  • *
  • Posts: 437
    • View Profile
  • Bike: 2013 Trophy
  • City / Town: Milwaukie, Or.
  • Country: USA
Re: Electrical problems log and discussions
« Reply #6 on: January 09, 2014, 07:01:30 PM »
*Originally Posted by Papermaker [+]
All--

In addition to various radio and communication problems the Trophy seems to suffer from at least four bike related electrical problems (I seen these problems mentioned several times by forum members).

-- Bad or weak batteries
-- Low voltage warnings while starting.
-- No response from the e-start when the starter button is pushed (at the start, middle or end of a ride).
-- Dead battery/bike after sitting overnight or longer.  Not caused be switch in park position.

I've experienced low voltage and no e-start response.  I was hoping that my bike had a weak/bad battery but that doesn't seem to be the case based on voltage drop while starting.

Are there other issues that I've missed?

--John

*Originally Posted by Papermaker [+]
Hi Coconut--

Thanks for the link.  If forum members are willing, I'd like to have a stand alone, active discussion of the electrical problems listed and others that I am not be ware of.

For instance, are these problems related?  A weak/bad battery may generate some of these issues but my battery and other forum member's batteries have been checked/replaced without correcting the issues.

I think that an active discussion will be helpful in resolving these issues,

--John

If Im not mistaken isn't this exactly what the 'Lighting, Electrical, and Wiring' board is already providing?
I am finding that the issues we seem to be experiencing here are being discussed on other forums. They aren't particular to the Trophy. The Tigers, Sprints, older Trophys etc are seeing some of the same issues. Lots of info out there.
The Database Coconut has started seems to be a pretty good resource for gathering a lot of this info in one location.
I still feel like the issues we see discussed here are experienced by a very very small segment of the Trophy owning community.
Brian
I have absolutely no idea what I'm talking about.
Riding the Northwet

Offline w8d4it

  • Trophy God
  • *****
  • Posts: 5337
    • View Profile
  • Bike: 2013 Triumph Trophy
  • City / Town: Houston Texas
  • Country: USA
Re: Electrical problems log and discussions
« Reply #7 on: January 09, 2014, 07:34:19 PM »
this forum has an excellent search facility
Proudly Riding Triumph Since 1968
2013 Triumph Trophy SE
2001 Sprint 955 ST

 



tweedy-bunch