Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: ECM replacement-Faulty ?????????  (Read 1732 times)

0 Members and 1 Guest are viewing this topic.

Offline Durnsey

  • Trophy Junior
  • *
  • Posts: 5
    • View Profile
  • Bike: Triumph Trophy SE
  • City / Town: Mid Wales
  • Country: UK
ECM replacement-Faulty ?????????
« on: March 17, 2014, 08:42:55 am »
 :110: Is the new ECM unit faulty also.  Since having my bike back from Triumph 10 days ago I lost power for a short while on the return from the ponderousa trip, then yesterday I travelled 5 miles to my local petrol station to get fuel ,then could not start the bike. The green neutral light does not show , the screen stayed down and the parking light came on. Checked all usual things, ie side stand and gears all to no avail. Recovery arrived couldn't do anything being taken back to dealer in Cardiff this morning .

Anyone else with similar problems :003: :003:

Offline Saaz

  • Trophy Master
  • ****
  • Posts: 1079
    • View Profile
  • Country: Australia
Re: ECM replacement-Faulty ?????????
« Reply #1 on: March 17, 2014, 09:37:14 am »
I have heard from my local Australian dealer that some of the replacement ECus have been faulty, and in some cases the bike ran worse so the original ECU was put back in.  The bikes were unrideable.  On his advice I am putting back any replacement until they have sorted it out. My Trophy runs fine at the moment so I want to keep it that way until things are sorted out.  Long term a replacement should be a good thing to avoid any future problems.

Offline Chaos

  • Trophy Master
  • ****
  • Posts: 965
    • View Profile
  • Bike: Triumph Trophy SE
  • City / Town: Hoyland
  • Country: UK
Re: ECM replacement-Faulty ?????????
« Reply #2 on: March 17, 2014, 04:48:55 pm »
*Originally Posted by Durnsey [+]
:110: Is the new ECM unit faulty also.  Since having my bike back from Triumph 10 days ago I lost power for a short while on the return from the ponderousa trip, then yesterday I travelled 5 miles to my local petrol station to get fuel ,then could not start the bike. The green neutral light does not show , the screen stayed down and the parking light came on. Checked all usual things, ie side stand and gears all to no avail. Recovery arrived couldn't do anything being taken back to dealer in Cardiff this morning .

Anyone else with similar problems :003: :003:

Had mine changed week before we all met up in Wales and to be honest I've no noticed a change in my bike at all. If it's back with the dealer that's got to be the best place for it as they will have the gear to sort it out. Could be just a coincidence  :087: but likely it could be a faulty ECU not be the first and not the last to be faulty straight out of the box "electronics you've just got to love em"
Hope you're sorted soon let us know the outcome  :028:

Chaos
Ride long & prosper.
Live to ride. Ride int rain.

Offline Durnsey

  • Trophy Junior
  • *
  • Posts: 5
    • View Profile
  • Bike: Triumph Trophy SE
  • City / Town: Mid Wales
  • Country: UK
Re: ECM replacement-Faulty ?????????
« Reply #3 on: March 25, 2014, 12:51:48 pm »
Bike back last Saturday, no faults found and starting ok now. Fingers crossed hope it doesn't happen again although I made sure the dealer logged my problem for future reference.

Looking at other posts I'm hoping that I got a broken wire or something similar