Author [ES] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [SE] [FI] [NO] Topic: No heated grip icon and grips don't work  (Read 3441 times)

0 Members and 1 Guest are viewing this topic.

Offline MNGreg

  • Trophy Member
  • **
  • Posts: 18
  • MNGreg
    • View Profile
  • Bike: Trophy SE
  • City / Town: Maple Lake
  • Country: USA
No heated grip icon and grips don't work
« on: April 25, 2014, 06:57:55 pm »
I am having the issue with the no heated grip icon and grips don't work. I saw in my kit the dealer didn't hook up a little 'do hickey'  :001: but in my research that part isn't needed on the grip kit, so not sure why it came with it. My dealer was going to look at the ecu flash for the grips when they did my GPS mount and first service.

Hopefully that is all it is for the two of us.

Offline malcolm

  • Trophy Pro
  • ***
  • Posts: 460
    • View Profile
  • Bike: Trophy 1200
  • City / Town: york
  • Country: UK
Re: No heated grip icon and grips don't work
« Reply #1 on: May 23, 2014, 11:02:28 pm »
" having the issue with the no heated grip icon and grips don't work. I saw in my kit the dealer didn't hook up a little 'do hickey'" 

That plug with the wire loop is what tells the ECU the grips are fitted. It pugs in under the glove box, if you open the glove box remove the 2 screws pull the box back and up you will see a similar connector without the wire loop just remove that and plug the new one in no programing required. I had the same problem but didn't have the loop connector so I just removed the plug and pushed a wire loop in the 2 pins.
« Last Edit: May 24, 2014, 12:36:47 am by malcolm »

Offline TerryB

  • Trophy Member
  • **
  • Posts: 38
    • View Profile
  • Bike: 2014 Trophy SE
  • City / Town: Valencia, CA
  • Country: USA
Re: No heated grip icon and grips don't work
« Reply #2 on: May 25, 2014, 05:36:18 am »
*Originally Posted by MNGreg [+]
I am having the issue with the no heated grip icon and grips don't work. I saw in my kit the dealer didn't hook up a little 'do hickey'  :001: but in my research that part isn't needed on the grip kit, so not sure why it came with it. My dealer was going to look at the ecu flash for the grips when they did my GPS mount and first service.

Hopefully that is all it is for the two of us.

Hello. You probably do need that "do hickey" which is the shorting link to enable the grip icon on the LCD display. Here is the confusion, there are 2 kits. A9638088 does not supply the shorting link and relies on the ECU/ECM to enable the grip icon on the LCD. A9638094 does supply the shorting link and does NOT rely on ECU/ECM to enable the grip icon on the LCD. My 2014 Trophy SE did need the shorting link and did not need anything enabled in the ECU/ECM.

If you have this connector under your cockpit storage, then you have A9638094 and you simply need to connect that shorting link to enable the icon.





You can find more info regarding the differences between the 2 kits in the grip install instructions:
http://triumphinstructions.com/ProdDocs/A9638094-EN.pdf

Hope this helps clear up some of the confusion.
Motorcycle and me, Motorcycle set me free - Daniel Ash

Offline 47BarnsleyLad66

  • Trophy Member
  • **
  • Posts: 32
  • 47BarnsleyLad66
    • View Profile
  • Bike: 13TriumphTrophySE
  • City / Town: Parksville,BC
  • Country: Canada
Re: No heated grip icon and grips don't work
« Reply #3 on: July 23, 2014, 07:45:17 pm »
My Heated grips did not work last sept when I needed them,I had not tried them for quite some time,the fuel tank was replaced in August.Dealer has ordered me new ones on warranty.

 



tweedy-bunch