Author [NL] [FR] [ES] [DE] [SE] [IT] Non starter  (Read 4609 times)

0 Members and 2 Guests are viewing this topic.

  • Offline spacca

    • Trophy Member  ‐    14
    • **
    • Topic Author

    Offline spacca

    • Trophy Member
    • **
    • Topic Author
    • Posts: 14
    • Bike: trophy
    • City / Town: reading
    Non starter
    on: Jun 14, 2017, 07.30 pm
    Jun 14, 2017, 07.30 pm
    Recently got the bike back after having a new engine
    fitted under warranty.(only took six weeks)

    Been using it for about 2 weeks ( about 150 miles) and it's dead again.

    Started fine then cut out whilst riding and nothing at all

    No horn, power to console or anything.

    Perhaps an immobiliser issue but would this happen on a running bike

    I'm rapidly losing faith in the brand.

  • Offline cropbiker   gb

    • Trophy God  ‐    4934
    • *****
      #1

    Offline cropbiker

    • Trophy God
    • *****
    • Posts: 4934
    • Midlands biker
    • Bike: Triumph Trophy SE
    • City / Town: Worcester
    • Country: gb
    Re: Non starter
    Reply #1 on: Jun 14, 2017, 08.02 pm
    Jun 14, 2017, 08.02 pm
    Dodgy battery connections? Solenoid connector come adrift?
    Triumph Trophy! Not for every Tomaz, Dieter or Herman!🇬🇧

  • Offline spacca

    • Trophy Member  ‐    14
    • **
    • Topic Author
    • #2

    Offline spacca

    • Trophy Member
    • **
    • Topic Author
    • Posts: 14
    • Bike: trophy
    • City / Town: reading
    Re: Non starter
    Reply #2 on: Jun 14, 2017, 08.40 pm
    Jun 14, 2017, 08.40 pm
    Battery connections fine, not checked the rest. The immobiliser light flashes when ignition is in the on position even though there is no power to the console. Would there normally be?

  • Offline Coconut   gb

    • Trophy God  ‐    10131
    • *****
      #3

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10131
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Non starter
    Reply #3 on: Jun 14, 2017, 08.45 pm
    Jun 14, 2017, 08.45 pm
    Definitely check the Main Battery Terminals are clean and tight.

    The wires to the Starter Solenoid can easily get knocked loose,
    but I would expect you to still have "power" showing on the Insttrument Panel,
    i.e. all the Warning Lights etc, so I'm wondering if this could be another case
    of a wire / wires becoming disconnected at the base of the Ignition Switch ?

    With the Ignition switched ON, try moving the handlebars fully from side to side -
    If Power suddnely comes back on, then that is likely to be the cause

    In any event, if you've only just had it back from the Dealer
    then that's the plasce for it to go back to and be sorted out.

    Let us know how you get on  :028:


    Last Edit: Apr 25, 2020, 05.41 pm by Coconut

  • Offline john348   gb

    • Trophy Master  ‐    1524
    • ****
      #4

    Offline john348

    • Trophy Master
    • ****
    • Posts: 1524
    • Bike: sprint1050 tiger955
    • City / Town: Farndon
    • Country: gb
    Re: Non starter
    Reply #4 on: Jun 14, 2017, 08.52 pm
    Jun 14, 2017, 08.52 pm
    Not trying to be condescending but one thing that keeps catching me out is I put my helmet down on the handlebars and catch the kill switch in the right hand side that stops everthing.  And for a second my heart is in my mouth when it does  nothing.

    But if it stopped when running can't be that.

  • Offline spacca

    • Trophy Member  ‐    14
    • **
    • Topic Author
    • #5

    Offline spacca

    • Trophy Member
    • **
    • Topic Author
    • Posts: 14
    • Bike: trophy
    • City / Town: reading
    Re: Non starter
    Reply #5 on: Jun 14, 2017, 09.05 pm
    Jun 14, 2017, 09.05 pm
    I will try the handlebar check tomorrow (bike is in work car park).

    Had to push bike back to work so can't imagine that's the problem.

    John348, I always flick on the kill switch when I park the bike up, would you advise against this in the future.

  • Offline john348   gb

    • Trophy Master  ‐    1524
    • ****
      #6

    Offline john348

    • Trophy Master
    • ****
    • Posts: 1524
    • Bike: sprint1050 tiger955
    • City / Town: Farndon
    • Country: gb
    Re: Non starter
    Reply #6 on: Jun 15, 2017, 08.25 pm
    Jun 15, 2017, 08.25 pm
    Not at all I don't personally use the kill switch apart from by mistake And it always worries me or a short time until I remember to check. 

  • Offline spacca

    • Trophy Member  ‐    14
    • **
    • Topic Author
    • #7

    Offline spacca

    • Trophy Member
    • **
    • Topic Author
    • Posts: 14
    • Bike: trophy
    • City / Town: reading
    Re: Non starter
    Reply #7 on: Jun 15, 2017, 09.13 pm
    Jun 15, 2017, 09.13 pm
    Spoke to Triumph this morning and they were pretty quick picking it up in there
    own van, not recovered like last time.

     



    tweedy-bunch