Author [NL] [FR] [ES] [DE] [SE] [IT] zumo 660 losing power and turning off  (Read 2701 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Hashadenough

    • Trophy Member  ‐    28
    • **
    • Topic Author

    Offline Hashadenough

    • Trophy Member
    • **
    • Topic Author
    • Posts: 28
    • Bike: 2017 Trophy SE
    • City / Town: Raleigh
    zumo 660 losing power and turning off
    on: May 14, 2018, 07.46 pm
    May 14, 2018, 07.46 pm
    Hi all,

    I could not find the answer on a search...

    I am about to dig into the bike looking for a short, I guess.  My Zumo 660 - in the US version Triumph cradle - has always worked great. Just yesterday it kept flashing the message of "External Power source lost, hit okay to continue on battery".  I didn't hit okay because I wanted to see if it would connect again. Sometimes it would "find" the power connection from the bike again, sometimes it wouldn't and it would turn off after the 30 second countdown.

    I tried removing it from the mount and re-connecting it a couple times and that didn't help. The pins all look good and it wasn't wet or anything.

    I wonder if anyone else has had this same issue and if it was just a bad connection at the power source, or if someone knows of a Garmin issue where this might indicate a problem with the gps unit itself???

    J
    2017 Trophy SE
    2017 HD Road King
    Gone:
    2004 Ducati ST3, 2011 HD Ultra Limited, 2005 HD Heritage, 2008 HD Street Glide, 2003 HD Road King

  • Offline ikkieman

    • Trophy Pro  ‐    220
    • ***
      #1

    Offline ikkieman

    • Trophy Pro
    • ***
    • Posts: 220
    • Bike: Silver Trophy SE
    • City / Town: Gouda
    Re: zumo 660 losing power and turning off
    Reply #1 on: May 14, 2018, 08.45 pm
    May 14, 2018, 08.45 pm
    Are the points on the GPS cradle and unit ok? On the zumo's, the pins can fail in some cases. Either on the cradle (more common) or on the GPS unit itself (rare occasions).
    There is nothing noble in being superior to your fellow man; true nobility is being superior to your former self.

  • Offline 1675   gb

    • Trophy Master  ‐    970
    • ****
      #2

    Offline 1675

    • Trophy Master
    • ****
    • Posts: 970
    • Bike: Trophy
    • City / Town: Spennymoor
    • Country: gb
    Re: zumo 660 losing power and turning off
    Reply #2 on: May 14, 2018, 10.56 pm
    May 14, 2018, 10.56 pm
    I have a 350 which was doing the same, always losing power going into, or coming out of towns and cities where I most needed it. The 350 fits into the Triumph bracket which has the Zumo cradle attached. The power comes via 2 spring loaded pins which seemed to have lost their "spring". A new lead with the pin assembly seems to have cured it.

  • Offline ladisney   us

    • Trophy Member  ‐    47
    • **
      #3

    Offline ladisney

    • Trophy Member
    • **
    • Posts: 47
    • Bike: 17 Trophy SE
    • City / Town: Pleasant Hill, Iowa
    • Country: us
    Re: zumo 660 losing power and turning off
    Reply #3 on: May 21, 2018, 05.25 am
    May 21, 2018, 05.25 am
    I had a similar issue with the GPS on my America.  Following my theory of always checking the easiest and cheapest things first I tracked it down to a faulty fuse with a hairline crack.  I've also seen corrosion in the fuse holder and a loose ground do the same thing.

  • Offline earthman   gb

    • Trophy Master  ‐    2121
    • ****
      #4

    Offline earthman

    • Trophy Master
    • ****
    • Posts: 2121
    • Country: gb
    Re: zumo 660 losing power and turning off
    Reply #4 on: May 21, 2018, 07.13 am
    May 21, 2018, 07.13 am
    I experience this occasionally over say a year, at the same time the volume of the radio goes right down or the 'No device' message appears even though I've just been playing it!
    I suspect that it's a software glitch to be honest, either that or a wire coming lose but it's a bit infrequent for the latter in my case I think & hope.

  • Offline jaapvanthoff   nl

    • Trophy Pro  ‐    201
    • ***
      #5

    Offline jaapvanthoff

    • Trophy Pro
    • ***
    • Posts: 201
    • Bike: TT SE my2014
    • City / Town: Rotterdam
    • Country: nl
    Re: zumo 660 losing power and turning off
    Reply #5 on: May 21, 2018, 08.28 am
    May 21, 2018, 08.28 am
    I had the same problem, no sound, or very low volume.
    Cleaning the contact pins in the holder and the brass contacts at the 660 with my hand gloves helped for some time.
    Solving this problem permanently was spraying with electric contact cleaner, without an oil/grease component.
    TTSE bleu
    ex: Dnepr, Ural, BMW's R1200RT :-))

  • Offline earthman   gb

    • Trophy Master  ‐    2121
    • ****
      #6

    Offline earthman

    • Trophy Master
    • ****
    • Posts: 2121
    • Country: gb
    Re: zumo 660 losing power and turning off
    Reply #6 on: May 21, 2018, 09.20 am
    May 21, 2018, 09.20 am
    I don't see how those contact pins have anything to do with the altering of the radio though.

     



    tweedy-bunch