Author [NL] [FR] [ES] [DE] [SE] [IT] Won't start after tank removal, fuel level not registered  (Read 6186 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Mr.Goodwill

    • Trophy Member  ‐    18
    • **
    • Topic Author

    Offline Mr.Goodwill

    • Trophy Member
    • **
    • Topic Author
    • Posts: 18
    • Bike: Trophy SE 1215
    • City / Town: London
    Won't start after tank removal, fuel level not registered
    on: Mar 31, 2019, 10.27 pm
    Mar 31, 2019, 10.27 pm
    Hello, greetings to All
    I posted the same message to the forum, but it despaired. So, here I go again …
    Recently I replaced air filter in my Trophy SE 1215 (2013). I drained fuel, but did not remove the tank completely, just lifted it up to gain access to the air filter compartment. I only disconnected battery, two fuel lines on both sides and two electrical plugs. Later reconnected everything as it was and fully charged the battery. Put about 15 liters of fuel. Now, I can’t fire up the engine. Furthermore, display screen shows that there is no petrol. The fuel gauge down to nothing and small fuel icon indicates, no fuel. I read somewhere, that if ECU did not correctly register fuel level, the engine will not start. I never had problems like that with any other bikes.  :440:  help.
    Vivamus, Moriendum Est (Latin) – ‘Let us live, since we must die.’

  • Offline earthman   gb

    • Trophy Master  ‐    2121
    • ****
      #1

    Offline earthman

    • Trophy Master
    • ****
    • Posts: 2121
    • Country: gb
    Re: Won't start after tank removal, fuel level not registered
    Reply #1 on: Mar 31, 2019, 10.55 pm
    Mar 31, 2019, 10.55 pm
    Is the starter motor turning the engine over, it's just not firing?

    Have you checked for any codes displayed on the dash?

    Tried disconnecting the battery, waiting for a while and tried again?

  • Offline nert   us

    • Trophy Pro  ‐    408
    • ***
      #2

    Offline nert

    • Trophy Pro
    • ***
    • Posts: 408
    • Bike: blue Trophy SE
    • City / Town: Hopewell, NJ
    • Country: us
    Re: Won't start after tank removal, fuel level not registered
    Reply #2 on: Mar 31, 2019, 11.05 pm
    Mar 31, 2019, 11.05 pm
    The scenario leads me to believe, there is an issue with the wire connector for the fuel pump and sensor during disassembly, and assembly.  I had a failed fuel sender on my Trophy, always reading empty, and the bike always started and would run. You may have lost power to fuel pump. Check fuse?

  • Offline 1675   gb

    • Trophy Master  ‐    970
    • ****
      #3

    Offline 1675

    • Trophy Master
    • ****
    • Posts: 970
    • Bike: Trophy
    • City / Town: Spennymoor
    • Country: gb
    Re: Won't start after tank removal, fuel level not registered
    Reply #3 on: Mar 31, 2019, 11.43 pm
    Mar 31, 2019, 11.43 pm
    If it was running before and now isn't, then re trace your steps. I would guess something has not been reconnected and should be an easy fix with a keen eye.

  • Offline Coconut   gb

    • Trophy God  ‐    10201
    • *****
      #4

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10201
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Won't start after tank removal, fuel level not registered
    Reply #4 on: Apr 01, 2019, 06.30 am
    Apr 01, 2019, 06.30 am
    The Fuel Gauge resets itself after a few minutes of normal riding,
    which is explained in the Owners Handbook, and is quite normal
    to show Empty at first immediately after refilling.

    Please explain the exact symptoms :

    What happens when you turn on the Ignition ?
    What happens when you press the Starter button ?
    Does the Starter Solenoid click when you press the Starter button ?
    Does the engine turn over when you press the Starter button ?

    Have you checked the obvious things like - the Handlebar Kill Switch ? (  :138: )
    Have you checked the various Safety Interlocks ?

    See this Topic : HOW TO : Check the most common faults & issues. Page 2 -
    Scroll down the alphabetically ordered list to ENGINE WON'T START.

    Cheers  :821:

    Last Edit: Jan 19, 2020, 05.12 pm by Coconut

  • Offline Mr.Goodwill

    • Trophy Member  ‐    18
    • **
    • Topic Author
    • #5

    Offline Mr.Goodwill

    • Trophy Member
    • **
    • Topic Author
    • Posts: 18
    • Bike: Trophy SE 1215
    • City / Town: London
    Re: Won't start after tank removal, fuel level not registered
    Reply #5 on: Apr 01, 2019, 09.05 am
    Apr 01, 2019, 09.05 am
    Hi, many thanks to All above
    Before, the bike was running perfect without any problems. When I turn Ignition ON, I can hear clicking solenoid, fuel pump priming, display screen confirms initialization process, no errors. Wind screen goes UP. The engine turns OK. Just doesn't fire up. The Kill Switch is OK, Side Stand up, Clutch engaged, gear "N". I checked all the fuel lines-OK, all connectors (from the pump and fuel lever sensor) connected.
    There is one unidentified connector which is not connected and I have no idea what it is for. Please see photo. I disconnected it while taking out the front lamp.
    Vivamus, Moriendum Est (Latin) – ‘Let us live, since we must die.’

  • Offline Coconut   gb

    • Trophy God  ‐    10201
    • *****
      #6

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10201
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Won't start after tank removal, fuel level not registered
    Reply #6 on: Apr 01, 2019, 01.17 pm
    Apr 01, 2019, 01.17 pm
    You don’t need to worry about that connector -
    It attaches to the Frame behind the left mirror pod,
    and is used on the US / Canadian export models
    for connecting the Satellite Radio antenna.

    Going back to a previous suggestion -
    Have you checked for any Fault Codes ( “DTC’s” ) ?



    Last Edit: Jan 19, 2020, 05.11 pm by Coconut

  • Offline Mr.Goodwill

    • Trophy Member  ‐    18
    • **
    • Topic Author
    • #7

    Offline Mr.Goodwill

    • Trophy Member
    • **
    • Topic Author
    • Posts: 18
    • Bike: Trophy SE 1215
    • City / Town: London
    Re: Won't start after tank removal, fuel level not registered
    Reply #7 on: Apr 02, 2019, 07.07 pm
    Apr 02, 2019, 07.07 pm
    Hi, thanks for the Plug info.
    I don't have any diagnostic tool to read fault codes. Build-in diagnostic does not indicate anything. I am considering purchase of DealerTool to do the DTC check. What really upsets me is the fact that this bike was running fine before... :023: . Is it possible, air lock in fuel pipes after draining the tank. Normally, fuel pump should force the fuel through any possible air lock. Why the gauge shows "no fuell" even when there is 15 liters in the tank, is still a mystery....
    Vivamus, Moriendum Est (Latin) – ‘Let us live, since we must die.’