Author [NL] [FR] [ES] [DE] [SE] [IT] Screen stopped working  (Read 2228 times)

0 Members and 1 Guest are viewing this topic.

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Screen stopped working
    on: Nov 03, 2019, 11.47 am
    Nov 03, 2019, 11.47 am
    Hello,
    My screen stopped working again and when I checked the wiring under the tank I too discovered the bad blue wire connection sitting in a wet loom. After repair the screen still would not work. I found the the screen arm pins ( the ones with the tension springs fitted) had not been fitted with retaining clips and had slid out from their bush holders. Both sides effected. I refitted them and the Screen still would not work. I then removed the screen motor and following another thread on this forum i placed a earth wire ont the black pin and yg onto pin 1. Nothing! When I removed the earth wire with yg to pin 1 and then fitted bp to pin 2 the motor worked. If I reversed the two wires the motor would reverse direction. Is the motor working as it should?

    Thanks....Wayne :183:

  • Offline Coconut   gb

    • Trophy God  ‐    10131
    • *****
      #1

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10131
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Screen stopped working
    Reply #1 on: Nov 03, 2019, 12.49 pm
    Nov 03, 2019, 12.49 pm
    Hi Wayne,

    As you've probably realised, the wiring for the Screen is quite complicated,
    with two Change Over Relays ( one for UP and one for DOWN ),
    the Handlebar UP and DOWN switches being connected via the Main ECM ( Connector B ),
    and the motor itself having Limit switches for the maximum UP and DOWN positions,
    together with a system for Memorising the position at Ignition Switch Off,
    and for restoration of that Position at Ignition Switch ON.

    Far too complicated to try and diagnose remotely via a Forum,
    beyond what has already been discussed in this Topic :

    Electric screen not working.

    At least you have had the motor moving, so it doesn't seem as though the motor itself has failed.

    It may just be that the Limit Positions need to be reset,
    which can be done by a Dealer, or use of the after market DealerTool device.

    I'd also be checking for correct operation of both Relays, which may have been affected
    when the main "Blue wire" failure occurred.

    Do you have a Service Manual - which has the Wiring diagrams
    for checking the various connections ?

    Cheers  :821:




    Last Edit: Nov 24, 2019, 12.50 pm by Coconut

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #2

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Screen stopped working
    Reply #2 on: Nov 03, 2019, 05.24 pm
    Nov 03, 2019, 05.24 pm
    Many Thanks for your reply.

    The screen operation was intermittent before failing completely. I used Dealer Tool to reset screen but it would only go up and then stop at maximum height. I discovered a badly spliced earthwire near where I eventually located the damaged blue wires to both relays which showed no voltage in pins 1 and 5. I tried Dealer Tool again after repair. Relays now had power and clicked with ignition on. The up and down control did nothing hence using Dealer Tool. Nothing happened. Perhaps you are right about the limit switches but I am not sure where the limit switches are located or if there is anotherway to reset them. I did swap around the relays and problem remained the same. I will replace them to rule them out of the equation.
    Also the auto jam/pinch may have something to do with it especially as the location pivot pins had popped out on one side of both arms. I do have the wiring diagrams. After exhausting all else I think you might be correct about the relays because even though they have power now to pins 1 and 5 and click, no power gets to the screen control buttons to activate the screen motor.

    I must say I was shocked by the quality of the harness and the way wires have been joined together. Very disappointed . I will keep on trying.

    Thanks...Wayne :087:

  • Offline Coconut   gb

    • Trophy God  ‐    10131
    • *****
      #3

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10131
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Screen stopped working
    Reply #3 on: Nov 03, 2019, 05.38 pm
    Nov 03, 2019, 05.38 pm
    I donít have access to the Wiring Diagram right now,
    but as far as I remember Power doesnít go to or from
    the Up and Down buttons ( switches ) from the Relays,
    the Buttons connect to the ECU.

    Cheers  :821:


    Last Edit: Nov 24, 2019, 12.50 pm by Coconut

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #4

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Screen stopped working
    Reply #4 on: Nov 03, 2019, 06.10 pm
    Nov 03, 2019, 06.10 pm
    Thanks Coconut,

    You are correct. My brain is now getting frazzled!  :087:

  • Offline wayne   gb

    • Trophy Member  ‐    41
    • **
    • Topic Author
    • #5

    Offline wayne

    • Trophy Member
    • **
    • Topic Author
    • Posts: 41
    • Bike: Trophy se 1215
    • City / Town: Sunderland
    • Country: gb
    Re: Screen stopped working
    Reply #5 on: Nov 08, 2019, 05.28 pm
    Nov 08, 2019, 05.28 pm
     :169:

    I thought Iwould give an update on my screen problem. I finally replaced the screen and it worked a treat. I discovered after doing all the pin tests on the old motor, the relay and Hal sensor were defective. I could get the motor to run but not when attached to everything else. I might be able to effect a repair on it when I have time and then have a spare.

    Many thanks to Dave at Triumph Newcastle for his expert guidance. They have a real passion for bikes.

    Cheers.. Wayne

  • Offline Coconut   gb

    • Trophy God  ‐    10131
    • *****
      #6

    Offline Coconut

    • Trophy God
    • *****
    • Posts: 10131
    • Bike: 2017 Trophy SE
    • City / Town: South Birmingham
    • Country: gb
    Re: Screen stopped working
    Reply #6 on: Nov 08, 2019, 07.35 pm
    Nov 08, 2019, 07.35 pm
    Thanks for the update Wayne  :028:

    Glad you now have it all working again.

    That's 2 Forum Members now that had the wiring connection
    within the loom under the back edge of the fuel tank fail,
    and not only had to repair that, but had to replace the Screen motor too.

    It would be interesting to know exactly what component failed, and why ?  :084:

    Cheers  :821:


    Last Edit: Nov 09, 2019, 05.11 pm by Coconut